Chain Initialization Error

So I have been mining for the last few months just fine from my home computer and cable connection. However the other day I noticed it wasnt running anymore. When I try to run nknd it spits out this error msg.

2021/08/14 09:11:50.891253 [ERROR] GID 1, chain.initialization error: leveldb/table: corruption on data-block (pos=951722): checksum mismatch, want=0x1c7ca754 got=0xc9b6d63a [file=13217166.ldb]

I have tried 3 times to download the new ChainDB from and each time I get the same error message. I also tried re-downloading the whole program from github and starting from scratch. But yet the same error still. I considered just letting the node sync the blocks from other nodes, but that was looking like it was going to take over a week at that rate.

Any suggestions would be greatly appreciated.

Rebooted, and now getting this one:

021/08/14 09:53:22.009128 [FATAL] GID 1, [nknd.go:L399 func1()] Panic: leveldb: internal key “\x02P_\xdc”, len=4: invalid length


Solved my issue by downloading the ChainDB directory from another one of my mining nodes instead of the snapshot from