Error starting Testnet Node

#1

I tried to setup an NKN testnet node under Windows 10. I have opened the ports 30000-30003 as TCP but am still getting an error when I try to start the node with “.\nknd.exe -p YOUR_WALLET_PASSWORD”.

The error says:

No NAT gateway detected, skip automatic port forwarding. You need to set up port forwarding and firewall yourself.

I have done both, disabled the Firewall as well as port forwarding but am getting this error. Can you please help me?

Thank you.

#2

This probably means your home router need to set up port forwarding. Do you have access to it? More details can be found here:

https://portforward.com/

#3

Thanks for your answer.

I already had the router set up for port forwarding and entered 30000-30003 as ports to be opened.

However, there still is one more field where the “triggering port” is being asked for. I have to enter a port which when being accessed from within my system, the predefined TCP/UDP port range (30000-30003) is being opened within my network.

I tried using 6112 as triggering port but it did not work.

Which port should I enter at “triggering port”?

Thanks a lot!

#4

“port triggering” is something I have no experience. what we have recommended is static port forwarding.

#5

Thank you but I dont seem to have the option for static port forwarding.

#6

This is how it looks like on my router. the field’s title is “ports to be forwarded” but what do I enter there, as there are four fields. I tried both:

30000-30003 -> 30000-30003

and

2302-2305 -> 30000-30003

but both versions of port forwarding still give me the same error that I described in the first posting:

No NAT gateway detected, skip automatic port forwarding. You need to set up port forwarding and firewall yourself.

#7

Hi, could you mind paste your console stderr output for details error log?

#8

I do not know if in the end you managed to solve it, but if it’s useful, I’ll tell you my situation.
My internet provider uses CG-NAT technology in which several users share the same public IP.
For this reason, I had to open the ports on my router, and call them to assign a fixed IP address and the forwarding of ports 30000-30003 to my router …
The problem happens when the public IP is renewed … Not so much with mining, but yes with monitoring of the node on the web testnet.nkn.org.
If you opened the ports of your router and still can not access ports 30000-3, try calling your provider to have them open for you.
Regards!

2 Likes