How to move node ID's?

How have you people moved your nodes? For example if your VPS starts to bill you for using cloud computers and you need to migrate your working node to another (free) server.

I found instructions on this forum and have tried this for two times now but haven’t gotten it to work. I get this error:

[email protected]:/home/nkn/nkn-commercial/services/nkn-node# ./nknc info -s
2021/05/09 23:39:30.982300 [ERROR] GID 1, POST request: Post http://localhost:30003: dial tcp 127.0.0.1:30003: connect: connection refused

Systemctl says that the service is running:

● nkn-commercial.service - NKN Commercial
Loaded: loaded (/etc/systemd/system/nkn-commercial.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2021-05-09 23:33:52 UTC; 9min ago
Main PID: 24233 (nkn-commercial)
Tasks: 45 (limit: 1151)
CGroup: /system.slice/nkn-commercial.service
├─24233 /home/nkn/nkn-commercial/nkn-commercial -d /home/nkn/nkn-commercial
├─24254 ./nkn-commercial service -d="/home/nkn/nkn-commercial/services" -b=NKNXfgWAhS4zpUJhj6M5mjM6fHNBiJww2PWr -c="/home/nkn/nkn-commercial/config.json"
├─24270 ./generator -r http://127.0.0.1:30003 -e 3600
├─24275 ./outline-server -s ss://AEAD_CHACHA20_POLY1305:@127.0.0.1:30488
├─24277 ./outline-server -c ss://AEAD_CHACHA20_POLY1305:@127.0.0.1:30488 -socks 127.0.0.1:30489
├─24284 ./goproxy -addr 127.0.0.1:30080
└─24644 ./nknd --password-file=wallet.pswd --beneficiaryaddr=NKNXfgWAhS4zpUJhj6M5mjM6fHNBiJww2PWr

But nstatus.org says this that the node is offline.

I am basically just moving wallet.json and wallet.pswd from the old node to the new one. Stopping and starting the nkn-commercial accordingly.

Can this happen if I haven’t stopped the original node service and start the new one with the old nodes ID? So that there is two nodes with same ID at the same time, for a while?

This problem is solved. As I pasted the content of old wallet.json file into the new one the editor (nano) splitted the text to three different lines. I thought it would not do that so I didn’t realise what had happened. Not until a friendly character on the NKN discord pointed out that there was something wrong with the wallet file. I edited the text in wallet.json so that all the text was in one line, there should be no “breaks” or “returns” in the middle, just one text on one line.