Mined NKN not showing in wallet

Why does NKN not show in my wallet even tho I have mined 22.20 NKN ?

Total Mined last 3 months

22.20 NKN



Mined rewards should be going to your beneficiary wallet.
Are you checking the correct wallet?
There is a local node wallet and beneficiary wallet.

Also, I am unsure how you ascertain what your mined rewards are without viewing them in your wallet.

what wallet?

I think I found the issue. The beneficiary address does not match the address in the NKN Web Wallet. Is there anyway to change the beneficiary address without creating a new node?

I can see mined rewards from dashboard > Node manager

NKN Web Wallet

You should have an actual beneficiary wallet set up from https://wallet.nkn.org
If this is the NKN Web Wallet you are referring to, then disregard.

You can change your beneficiary address from
The settings tab is where you can change it.

Hope this helps.

Yes I have the same wallet you recommended.

The link to change beneficiary address doesn’t work. I just get this message “ERR_CONNECTION_REFUSED” I have tried it on a few browsers with no firewall and it still doesn’t work. Have you got another link?


You can set the beneficiary address in the config.json file, normally in the same folder as nknd and wallet.json.

For Windows:
It’s in the folder you put it in, I think, I didn’t set up a node on my Windows machine.

For Linux:
If you used fast deploy nkn is located in
otherwise with a pre-built, like Google, I believe the path is
Otherwise it will be in the folder you placed it.

Here is an example config.json, I used nano to edit mine:
nano /home/nknx/nkn-commercial/services/nkn-node/config.json

"BeneficiaryAddr": "{beneficiary_address}",
"SeedList": [
"GenesisBlockProposer": "a0309f8280ca86687a30ca86556113a253762e40eb884fc6063c$

Added Note: If you are going to edit the config on Linux and are using the commercial service, I would shut it down and restart it after editing the config.

  1. Temporarily shut down: sudo systemctl stop nkn-commercial.service
  2. {edit the config}
  3. Start back up (reboot also works): sudo systemctl start nkn-commercial.service

Otherwise, if using commercial, you also have the option to set the beneficiary address through launch parameters or its own settings in /home/nknx/linux-amd64/config.json, but the main nodes config file should be suffice.

Also see: NKN Docs :: Get Started - Using Beneficiary Address

Also, I believe, if you have not set a beneficiary address then the tokens are put in the nodes wallet. The address for that should be in wallet.json and the password should be in wallet.pswd.

If you find they are in that wallet, you can easily transfer them to your beneficiary through the web wallet. Just select the wallet.json file and enter the password that’s inside the wallet.pswd file.

NKN Web Wallet

I’m a real newbie to this. I have a MacBook Pro and use DigitalOcean. Can I still change the address using this setup with your suggest method ?


Yes, but if you are new to remoting into terminals then it can be tricky.

I used DigitalOceans trail value years ago for my ASP.NET class, so I’m not 100% sure but…

First off, I’m not sure if DigitalOcean has a tool on site that connects to the server terminal (opens a new browser window with the terminal), but that would be easiest. This will directly connect you to the terminal to allow you to edit the config file.

Otherwise If you have not setup SSH keys (default for DigitalOcean), then signing in is not too difficult. You can use a program like putty or since you have OSX you can use the OS terminal directly.

DigitalOcean has a guide on connecting to your server.

How to Connect to Droplets with SSH

Another Edit: A quick guide on using nano just incase.
How to Use Nano, the Linux Command Line Text Editor

Basically once signed into the terminal you need to stop the NKN node service then edit the config file (using nano in my example), and start the service back up.

General Steps (may differ slightly, I don’t use OSX, nor DigitalOcean):

  1. From an OSX terminal you can use the following to connect to the server.
    ssh [email protected] - replacing the IP with your droplets address, and username with the droplets username (root by default, I think).

    • You will be asked for the password for the server, this is the same password you enter when prompted when first using the sudo command, unless you are using a password for a SSH key, but you would know having set it up. If the user is root you don’t need to use sudo before each command since sudo simply gives the current user root access to the command being ran.
  2. Then you can use ls to find your directory.
    ls /home - will list the home directories and you should see one as nkn or nknx.

  3. Stop the NKN service with:
    sudo systemctl stop nkn-commercial.service

  4. Find and edit the config with:
    nano /home/nknx/nkn-commercial/services/nkn-node/config.json

  5. Start the service back up or reboot with:
    sudo systemctl start nkn-commercial.service
    sudo reboot now

    • If you reboot, you will get kicked out of the session right away, otherwise type exit when done to disconnect out of the terminal. You can also just close the terminal on OSX.
  6. You can check the status from the terminal after starting back up or rebooting with:
    sudo systemctl status nkn-commercial.service - Press ‘q’ after to type more commands.

    • Also, I noticed at times using status will show its running, but it may be hanging up on an issue. You then can print the log to see. You can print the current log with:
      cat /home/nknx/nkn-commercial/services/nkn-node/nkn-node.log
  7. Should be done.

1 Like

Also some good posts if you are interested.

1 Like

I’m sorry, my link that i sent you was if you had a node running locally on the machine you are on.
At least that is how I have been using it.
I don’t have any cloud nodes set up currently, so I am unable to help you.

1 Like

Hello, I was wondering if I was having the same issue as I mined 3 blocks today but didn’t receive any of them in my wallet. I followed the steps Mitchell provided to check the beneficiary address of one of my nodes. The beneficiary address was blank… How is this possible? I set this node up using fast deploy and put my beneficiary address in, as evidenced on nknx where the beneficiary address is listed with my node label. Why is my beneficiary address blank? I will now have to go through all of my nodes and check them to make sure it is not blank. I have received some mining rewards and all of my nodes were set up in the same exact way so I am at a total loss to explain this.

Edit: Just checked my first 10 nodes, 9 were blank 1 actually had the beneficiary address… wtf

Edit #2: I looked at recent events on nknx, it seems that 2 of the 3 blocks I mined today were donated to NKNx, I was wondering if nodes previously deployed would still have to donate or if the update to fastdeploy cancelled that. I guess that answers my question. However, the third block was not donated and I checked my node wallet and it is not in there. Beneficary address listed as blank in config.json so curious where that reward went, and why my beneficiary addresses keep coming up blank.

This has me kind of stumped. I think one of that staff members will need to help with this if they haven’t already.

I do remember reading on the quick deploy page that when using it the first reward goes to NKN. I also noticed that quick deploy uses the commercial service which sets the beneficiary address through launch parameters. You should see your beneficiary address if you use systemctl status nkn-commercial.service. I just decided to edit the configs myself when I noticed they didn’t have an address. Not completely sure if it was necessary, but I wanted to be safe, and after hearing this, maybe it was a good idea.

Edit: You may want to look at /home/nknx/linux-amd64/config.json (With linux-amd64 replaced with your system) I believe this config dictates the launch parameter the commercial service uses when launching nknc.

Example /home/nknx/linux-amd64/config.json file with beneficiary override:
{ "beneficiaryAddr":"ADDRESS_HERE", "nkn-node": { "noRemotePortCheck": true } }


Thanks for the response. Upon further inspection I don’t think I was actually having a problem at all. When I went through and checked all my nodes only one already had the beneficiary address in config.json, so it must not be necessary for fast deploy considering I had received rewards from multiple nodes already. Also, I think I was confused about what had happened with the 3 blocks I had mined that day. I am on Eastern Standard Time and assumed NKNx was as well, so I think when I saw that 3 blocks had been mined that day I was expecting them to have all been received in my mining address or donated within what was my Monday. It seems what happened was a block was mined ‘yesterday’ for me, but not for NKNx, and it actually went to my beneficiary wallet but I was ignoring it because it wasn’t from ‘today’. So it seems there is no issue there. Thanks for all your help, and the next time I spin up a new node with fast deploy I will check the launch parameters for the beneficiary address. I am wondering though, is there a way to see a nodes mining history, for example showing the timestamps of all blocks it has mined? I know you can see ‘Mined today’ and ‘Mining History’ on NKNx, and you can use the wallet tracker, but I would like to see when each block I have earned was earned, and what node earned it. Obviously I can see mining rewards in my wallet on explorer.nkn, but I can’t see the fast deploy donations to NKNx and I also don’t know how to figure out which node mined which reward. The 'Recent Event’s on NKNx shows when a donation was made, but it only goes back so far, and it doesn’t say which node made the donation.

Ya, I have that same problem. Each node has counter that resets to 0 when it resets or updates.

I made a shell script to that I run with WSL on my Windows machine. I run that periodically and tally up nodes that have earned rewards.